Skip to content Skip to main menu Skip to utility menu

Categories in Document Finder

Home Forums GovIntranetters Categories in Document Finder

This topic contains 7 replies, has 3 voices, and was last updated by  Luke Oatham 2 years, 10 months ago.

  • Author
    Posts
  • #1288

    lizb
    Participant

    Hi,

    At the moment I am setting up basics and will not be using this template for a local government but using it as an intranet for a company I work for – they just need it as a quality management system, providing access to documents, templates and manuals etc.

    At the moment I am trying to add categories; I am very confused as to where you mentioned “Edit attachments in the media library to add a category and document type” but there isn’t any categories mentioned in there? Only document type…

    I am trying to use categories as a department e.g. Finance & Admin, Marketing etc. so the links would work to display relevant documents but none of it is working at the moment?

    Any help would greatly be appreciated. I didn’t realised by unpacking this theme would come with a lot of configuration and adjustments – where I thought I’d just install the theme and it’d be ready for me to build..

    Thanks,
    Liz

  • #1289

    Dazbert
    Participant

    Hi there,

    It sounds like you need to install the plugin media categories. This will give you that functionality.

  • #1292

    lizb
    Participant

    Ah brilliant! Thank you Dazbert – that works. Now the next problem is that when we click on the link of a category or a document type, it takes me to 404 error page, instead of filtering the type of document within a category…

  • #1293

    Dazbert
    Participant

    Try resaving your categories, this usually clears the problem for us. As for finding the cause, check your error.log and <your-website>error.log

    For us it was caused by the poll addon not working properly

    good luck!

  • #1294

    lizb
    Participant

    Thank you for your response, but I don’t have error.log and poll addon anywhere in the files I’ve got here. I have had no problems with WordPress in the past but this theme is getting too complicated for me – it should’ve been simple to use instead of all sorts of menus in my dashboard, I don’t have any/tiny experience in html/css as I am only a designer. This theme is the only appropriate design layout for company’s intranet.

    It might be to do with the link… for an example yourwebname/wordpress/?page_id=147 instead of yourwebname/wordpress/documentfinder… I have tried to change from default to post name but that didn’t work in permalinks, so I went back to default and currently displaying page id numbers.

  • #1295

    Dazbert
    Participant

    It does sound like a permalink issue. things to check

    The error logs would be on the server in the /log/apache*.*/ directory

    1) Make sure you have created a tasks-by-catgory page

    https://help.govintra.net/task/create-pages/

    2) In Settings>Permalinks – set it back to post name. Whenyou click ‘save changes’, does it give you a message along the lines of ‘you must update your htaccess file now’ If so you need to get somone with experience in setting up wordlpress to update this file on the server.

    3) If 1 and 2 dont work, once you have set permalinks to post name, go back into a category and resave it along with any content created. This should update the links to make sure everything works as it should.

    Thats about all i can suggest, maybe Luke and the theme creators can suggest something.

  • #1296

    lizb
    Participant

    Hi,

    It is a permalink issue. To check first before I go and play with the “web.config” (that’s the message that comes up when I chose to select a post name), I dived in page-doc-finder.php file with a dev colleague of mine (he is very busy with other work projects at the moment which is why I am trying to deal this WordPress by myself) and renamed “document-finder” with “/?page_id=$id&” instead – and that worked and solved the issue. One downside is that I have a post id instead of post name in the URLs. I have opened up the web.config file and it doesn’t show much in there.

    Thank you for your help dazbert – I will try and ask Luke if he can shed some light on how to solve the permalink issues for post name.

    Thanks,
    Liz

  • #1307

    Luke Oatham
    Keymaster

    Hi Liz and thanks for your help Dazbert!

    Can I check that your slug for the document finder is “document-finder” and that you have set the template in Page attributes to Document finder?

    To get permalinks working correctly you may need to edit the .htaccess file on your server if WordPress can’t write to it directly. There is normally a message when you try to change permalinks containing the code that you need to add to .htaccess.

    Luke

You must be logged in to reply to this topic.