Skip to content Skip to main menu Skip to utility menu

error on publish

Home Forums GovIntranetters error on publish

This topic contains 4 replies, has 2 voices, and was last updated by  Andrew S 8 months, 2 weeks ago.

  • Author
    Posts
  • #3507

    Andrew S
    Participant

    Hi

    I am using a plugin called eventon, for calendar events. When the event is in draft it is visible, however when I publish it, it can not be found.

    I generated a log and get the info below – I spoke to the plugin creator and they suggest the theme is at fault. I am using a child theme of the gov one.

    I have had a good search online but I am drawing a blank, any suggestions would be welcome

    thanks

    [21-Feb-2019 09:57:49 UTC] PHP Notice: Trying to get property of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/themes/govintranet/functions.php on line 4652
    [21-Feb-2019 09:57:49 UTC] PHP Notice: Trying to get property of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/themes/govintranet/functions.php on line 536
    [21-Feb-2019 09:57:49 UTC] PHP Notice: Trying to get property of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/themes/govintranet/functions.php on line 545
    [21-Feb-2019 09:57:49 UTC] PHP Notice: Trying to get property of non-object in /opt/bitnami/apps/wordpress/htdocs/wp-content/themes/govintranet/functions.php on line 547

  • #3508

    Luke Oatham
    Keymaster

    Looks like you might have the GovIntranet ‘events’ module switched on, which may be clashing with your eventon plugin. If so, could you try turning it off?

  • #3510

    Andrew S
    Participant

    I turned off the HT events plugin but no joy
    I added the eventon widget and that seems to work, but linking to the events page (in order to keep things clean and concise doesn’t)
    I am happy with where it is at the moment, unless I get told to change the appearance, so thanks for the help to date

    Andrew

  • #3511

    Luke Oatham
    Keymaster

    In Options, Modules – have you got Events switched on? It should be off.

  • #3517

    Andrew S
    Participant

    thanks for the suggestion – now solved
    I checked option – modules and it was off, and i could not turn it on, possibly as I had disabled the addin
    so I looked at options in event on, and flicked the value Select calendar event content filter type between eventon and word press, and that made it burst in to life – so solved but without really knowing the underlying issue

    thanks for your help

You must be logged in to reply to this topic.